System Status

System Status

Welcome to Ping Identity's system status site.

System Uptime

System Uptime

System uptime in the past 90 days.

Past Incidents Past Incidents

Welcome to Ping Identity's system status site.

PingID "Security Key" authentication method is unavailable for a small number of customers

Incident Report for Ping Identity

Resolved

This incident has been resolved.
Posted Jul 29, 2025 - 17:38 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 29, 2025 - 15:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 29, 2025 - 15:07 UTC

Identified

The issue is identified and a fix is being implemented.
Posted Jul 29, 2025 - 08:48 UTC

Investigating

A few PingID customers reported issues with security key options being unavailable when users authenticate. Furthermore, attempting to update the policy in the admin web UI triggers an "[error.internal]" error. The engineering team understands the root cause of this problem and is actively working to address this issue.

For additional questions please contact Ping Identity Technical Support by opening a case through the Ping Customer Portal (https://www.pingidentity.com/en/account/sign-on.html), or follow this incident on https://status.pingidentity.com for real-time service updates.
Posted Jul 29, 2025 - 05:42 UTC
This incident affected: PingID - Australia (.com.au services) (PingID Server), PingID - Europe (.eu services) (PingID Server), and PingID - United States (.com services) (PingID Server).