System Status

System Status

Welcome to Ping Identity's system status site.

System Uptime

System Uptime

System uptime in the past 90 days.

Past Incidents Past Incidents

Welcome to Ping Identity's system status site.

Elevated latency and error rate for PingOne Audit UI and Activities Endpoint

Incident Report for Ping Identity

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 23:28 UTC

Update

We've taken action to bring the latency and error rates down to normal levels since 22:33 UTC.
Posted Mar 30, 2026 - 23:27 UTC

Investigating

In NA we're investigating alerts related to an increased error rate and latency for the activities endpoint, which exposes PingOne audit data in the Admin UI. End user use cases are unaffected.
Posted Mar 30, 2026 - 22:09 UTC
This incident affected: PingOne and PingOne Services - United States (.com services) (Admin Console Dashboards).