System Status

System Status

Welcome to Ping Identity's system status site.

System Uptime

System Uptime

System uptime in the past 90 days.

Past Incidents Past Incidents

Welcome to Ping Identity's system status site.

PingID Authenticator Delays
Incident Report for Ping Identity
Postmortem

On February 26, 2021 at 13:00 UTC Twilio’s Outbound SMS API experienced high error rates and stopped responding to requests in a timely fashion. This action caused unscalable resource consumption on our PingID servers which in turn degraded on all authentication traffic. The SRE team worked quickly to disable traffic to Twilio, in order to mitigate the immediate issue and maintain service levels for all other PingID authentication solutions. At 15:14 UTC the Twilio’s outbound SMS API service was restored. Outbound SMS services were restored shortly thereafter.

We are working with our service partner and application teams to further improve our services.

Posted Mar 02, 2021 - 23:22 UTC

Resolved
This incident is resolved. We will continue to monitor the situation.
Posted Feb 26, 2021 - 19:06 UTC
Monitoring
All services appear to be passing again, including SMS and VOICE. We will continue to intensively monitor the situation and rapidly re-bypass should there be further issues.
Posted Feb 26, 2021 - 15:35 UTC
Update
We have made changes to bypass the degraded SMS and Voice service. Customers are advised to authenticate via other solutions until https://status.twilio.com/incidents/zmz5c9prz8mm is resolved.
Posted Feb 26, 2021 - 15:00 UTC
Identified
Escalated to Partial Outage as we are seeing failures as well as delays. We're working to alleviate the issue.
Posted Feb 26, 2021 - 14:01 UTC
Update
We are continuing to investigate this issue.
Posted Feb 26, 2021 - 13:49 UTC
Investigating
We're aware of a Twilio service issue: https://status.twilio.com/incidents/zmz5c9prz8mm
The impact for our customers appears to be a delay in authentication speed - we apologise for any inconvenience and are working to resolve with them.
Posted Feb 26, 2021 - 13:49 UTC
This incident affected: PingID - Europe (.eu services) (PingID Authenticator), PingID - Australia (.com.au services) (PingID Authenticator), PingID - United States (.com services) (PingID Authenticator), and Twilio (SMS).