Degraded OTP email delivery to Microsoft Exchange Online customers
Incident Report for Ping Identity
Resolved
This incident has been resolved.
Posted May 10, 2021 - 20:35 UTC
Monitoring
A number of customers who reported they were impacted by this issue are now reporting successes. No changes were made to the Ping infrastructure at this time.
Posted May 10, 2021 - 16:53 UTC
Investigating
We are investigating an issue whereby customers using Microsoft Online Exchange services are unable to reliably receive OTP (One Time Passcode) emails. Our initial checks confirm that all our outgoing messages leave our services correctly and are being handed off to 3rd parties successfully. We are working with customers to identify the root cause of the issue.
Posted May 10, 2021 - 12:22 UTC
This incident affected: PingID (Email OTP).