System Status

System Status

Welcome to Ping Identity's system status site.

System Uptime

System Uptime

System uptime in the past 90 days.

Past Incidents Past Incidents

Welcome to Ping Identity's system status site.

Delays in SMS Messages
Incident Report for Ping Identity
Resolved
Twilio has updated that services are operationing normally.
Posted Aug 15, 2017 - 18:12 UTC
Monitoring
Twilio has updated their status and are monitoring their services as they recover.
Posted Aug 15, 2017 - 17:56 UTC
Investigating
Our upstream SMS provider (Twilio) is experiencing delays with SMS deliveries affecting US and CA. Messages are delayed by up to 15 minutes. Please see the following link for status at Twilio: https://status.twilio.com/incidents/qb7m3jd3mm03
Posted Aug 15, 2017 - 17:13 UTC
This incident affected: Twilio (SMS).