Voice based MFA Outage
Incident Report for Ping Identity
Postmortem

On November 18th PingID Voice OTP services experienced a 10x increase in outbound voice traffic requests from 13:07 UTC until 14:17 UTC. This increased traffic queued calls within our service provider. Service remained degraded until 17:44 UTC when we were able to increase capacity to clear the call queue backlog. Capacity increases remain in place to handle future spikes.

All other transmission services such as SMS, email and push notifications were not affected.

Posted Nov 20, 2020 - 21:32 UTC

Resolved
This incident has been resolved.
Posted Nov 18, 2020 - 19:08 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 18, 2020 - 18:07 UTC
Identified
The issue is identified and we're working with our partner for voice-based MFA to resolve it.
Posted Nov 18, 2020 - 17:19 UTC
Investigating
We are aware of an issue with Voice-based OTP communications which is affecting our customer base. We are working with our provider on this critical path issue. We apologise for any inconvenience.
Posted Nov 18, 2020 - 16:45 UTC
This incident affected: PingID (PingID Server - North America (.com), PingID Server - Europe (.eu), Twilio PSTN).