System Status

System Status

Welcome to Ping Identity's system status site.

System Uptime

System Uptime

System uptime in the past 90 days.

Past Incidents Past Incidents

Welcome to Ping Identity's system status site.

PingOne Intermittent AD Connect Failures
Incident Report for Ping Identity
Postmortem

Incident Summary

An increase in transactional SSO traffic resulted in timeouts to the backend application servers.

Customer Impact

Customers running ADconnect Agent experienced intermittent login failures.

Incident Timeline - June 13, 2017

  • 2332 UTC - Customer contacts support regarding increased login failures.
  • 0056 UTC - Support escalated to SRE and DEV teams.
  • 0126 UTC - Error rates decreasing.
  • 0224 UTC - Error rates decrease to normal. Internal testing confirms issue resolved. SRE team continues monitoring the system
  • 0336 UTC - Issue confirmed resolved.

Affected Services

  • PingOne SSO using ADConnect

Over 400 customers accessed this service and 3 reported a problem as it was very intermittent. We believe that 25 customers may have had a problem but even then it was a very small percentage compared to the number of successful transactions.

Resolution

Issues resolved itself after customer transactional SSO traffic returned to normal.

Ping Action Items

  • Add additional backend nodes to help distribute the load more evenly (Completed)
  • Add ADC error monitoring to the PingOne SSO Monitoring dashboard (Completed)
Posted Jun 23, 2017 - 19:11 UTC

Resolved
This issue has been resolved.
Posted Jun 14, 2017 - 03:36 UTC
Monitoring
Error rates are decreasing and the Site Reliability team is monitoring the system.
Posted Jun 14, 2017 - 02:24 UTC
Update
The Site Reliability team is still investigating the increased error rates. Next status update will be posted at 2030 MT.
Posted Jun 14, 2017 - 02:04 UTC
Update
The Site Reliability team is still investigating the increased error rates. Next status update will be posted at 2000 MT
Posted Jun 14, 2017 - 01:47 UTC
Update
The Site Reliability team is still investigating the increased error rates. Next status update will be posted at 1945 MT.
Posted Jun 14, 2017 - 01:21 UTC
Investigating
Site Reliability Engineers are investigating issues with the AD Connect service. We will update this message when the incident has been identified.
Posted Jun 14, 2017 - 00:56 UTC
This incident affected: PingOne for Enterprise - Global (AD Connect & Routing Service).